Linux не работает передняя панель для наушников

Linux не работает передняя панель для наушников

16 июн 2017, 12:05

Здравствуйте, уважаемые любители Linux Lint!
Помогите, пожалуйста, у меня странная проблема, решить самостоятельно не удается (Мучаюсь уже 3 месяца ).

Проблема такая вот, раньше стояла Ubuntu 14.04 x32, проблем никаких не было. Ну как и все любящие новинок, решил я себе обновить систему до 16.04, но решил поставить x64, вот поставил вроде бы все нормально, но через некоторое время заметил проблему, а именно, почему-то звука в наушниках вообще нету.
Ну и я пошел лазить в настройки alsa (

$ alsamixer).
Обнаружил, что headphon стоит MM (Mute), а что же мне делать, я снял MM поднял до конца и вуаля, работает!
Но, что самое интересное, то что после перезагрузки все возвращается на свои места(То есть, опять нету звука в наушниках).
Через несколько месяцев поставил Linux Mint 18.1, и та же проблема здесь.
PS: и в PavControl так же, сбрасываются настройки.

Что мне делать? Как быть? Может есть знающие люди, которым все же не лень будет помогать мне, отзовитесь, пожалуйста.

Немного технической информации: Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)

LevonX , в alsamixer ‘e правей есть еще такой пункт как Auto-Mute Mode

И вот здесь еще можно почитать по смене дефолтного канала на уровне пульсы — помогите настроить выход на наушники

Источник

Нет звука в наушниках через аудио порт на передней панели в Ubuntu 18.04

Когда я подключал наушники к порту ЦП на передней панели, я не слышал никакого звука, фактически он не мог обнаружить наушники. Но когда я подключаю его в порт на задней панели, он может обнаружить. И звуковая коробка также работает нормально с задней панели, но не с передней панели. Эта проблема возникает только тогда, когда я использую Ubuntu 18.04, но в Windows 10 Pro она отлично работает с обеих панелей (я использую Win 10 и Ubuntu 18.04 в режиме двойной загрузки). Моя конфигурация процессора: 3,5 ГГц Intel G-4560, материнская плата H110M PRO VH Plus MSI, графический процессор Intel HD 610. Это проблема из-за драйверов? Если так, то как это исправить (или как установить)? Или любое предложение, как это исправить. Заранее спасибо!

3 ответа

Я была такая же проблема. Этот ответ ниже помог мне

Когда вы используете Alsamixer, обязательно сделайте следующее:

  1. Включите наушники, нажав M
  2. Отключить автоматическое отключение звука
  3. Поиграйте с уровнями громкости «Front», «PCM» и т. Д., Пока не услышите звук в наушниках (вот что помогло мне)

Также обратите внимание, что громкость наушников по-прежнему будет показывать ноль в Alsamixer по какой-то причине, но звук все равно будет там. Если вы хотите получить большую степень контроля над микшером, кто-то порекомендовал qashctl . проверьте это. Для меня Alsamixer сделал работу, поэтому я не стал беспокоиться

Рекомендуем:  Dp290 колонка вольво пента

Это сработало для меня. Думал, что лучше поделиться этим подробно.
В «Терминал» напишите alsamixer

В «AlsaMixer» выберите «Наушники», используя боковые клавиши на клавиатуре.

Теперь нажмите m в клавиатуре (мышь не работает здесь) для включения наушников. (Когда наушники отключены, вы можете увидеть в столбце, который показывает MM и после включения наушников он покажет OO )

Нажмите клавиши со стрелками вверх-вниз для управления звуком в наушниках.
Теперь, чтобы сохранить конфигурацию, запустите эту команду:
sudo alsactl store
Поэтому в следующий раз, когда вы откроете свой компьютер, он загрузится с этой конфигурацией.

Сегодня я столкнулся с той же проблемой, что я не слышу звука, если подключены наушники, даже не могу проверить его в настройках> звуки, но могу правильно слышать, если наушники не подключены с помощью встроенного динамика ноутбука.

Я сослался на все доступные решения, и даже после изменения его с mm на 00 он не позволял мне слышать звук в наушниках.

Я использовал Lenovo ideapad и проверил другие доступные варианты, и он показывал F6 для звуковых карт, поэтому я попытался нажать его, но не показал мне никаких доступных карт.

Затем я нажал функциональную клавишу + F6 и смог увидеть USB2.0, который был моими наушниками. Итак, выберите его, а затем нажмите m и увеличьте его с 00, нажав клавишу со стрелкой вверх, и после этого вы сможете правильно слышать звук.

Я надеюсь, что это помогает.

После последней строки добавьте новую строку. Эта строка позволяет ноутбуку распознавать звуковую карту. Моя звуковая карта называется CA0132. Вы можете найти название звуковой карты: cat /proc/asound/card0/codec* | grep Codec

Далее введите команду:

В открывшемся окне: включите опцию «HP/Speaker Auto Detect»

Примечание: после выполнения вышеуказанных действий вы также можете попытаться перезагрузить компьютер. Иногда это делает свое дело.

Источник

Нет звука в наушниках с аудиовхода на передней панели в Ubuntu 18.04

Из-за запроса в списке рассылки CWB я узнал, что кэш, о котором идет речь, поддерживается приложением (cqpweb) и что обновления Ubuntu на php и mysql не являются проблемой.

2] В моем случае решение состоит в том, чтобы увеличить кеш приложения.

6 ответов

У меня была такая же проблема. Этот ответ ниже помог мне

Аудиоустройство передней панели не работает в Ubuntu 16.04

Когда вы используете Alsamixer, обязательно выполните следующие действия:

Включить звук Наушники, нажав M Отключить Автомат. Воспроизведение с уровнями громкости «Фронт», «PCM» и т. Д., Пока вы не услышите звук в наушниках (вот что сделал трюк для меня)

Также обратите внимание что громкость наушников по-прежнему будет показывать ноль в Alsamixer, но звук все равно будет там. Если вам нужна более высокая степень контроля над микшером, кто-то рекомендовал qashctl . проверить это. Для меня Alsamixer выполнил эту работу, поэтому я не стал беспокоиться

У меня была такая же проблема. Этот ответ ниже помог мне

Аудиоустройство передней панели не работает в Ubuntu 16.04

Когда вы используете Alsamixer, обязательно выполните следующие действия:

Включить звук Наушники, нажав M Отключить Автомат. Воспроизведение с уровнями громкости «Фронт», «PCM» и т. Д., Пока вы не услышите звук в наушниках (вот что сделал трюк для меня)

Также обратите внимание что громкость наушников по-прежнему будет показывать ноль в Alsamixer, но звук все равно будет там. Если вам нужна более высокая степень контроля над микшером, кто-то рекомендовал qashctl . проверить это. Для меня Alsamixer выполнил эту работу, поэтому я не стал беспокоиться

Рекомендуем:  Как отключать питание на сабвуфер

У меня была такая же проблема. Этот ответ ниже помог мне

Аудиоустройство передней панели не работает в Ubuntu 16.04

Когда вы используете Alsamixer, обязательно выполните следующие действия:

Включить звук Наушники, нажав M Отключить Автомат. Воспроизведение с уровнями громкости «Фронт», «PCM» и т. Д., Пока вы не услышите звук в наушниках (вот что сделал трюк для меня)

Также обратите внимание что громкость наушников по-прежнему будет показывать ноль в Alsamixer, но звук все равно будет там. Если вам нужна более высокая степень контроля над микшером, кто-то рекомендовал qashctl . проверить это. Для меня Alsamixer выполнил эту работу, поэтому я не стал беспокоиться

Это сработало для меня. Подумал, что было бы лучше поделиться им тщательно. В «Terminal» напишите alsamixer

В «AlsaMixer» выберите «Headphone» с помощью клавиш со стрелками в клавиатуре.

Теперь нажмите m в клавиатуре (доза мыши не работает здесь), чтобы включить наушники. (Когда наушники отключены, вы можете увидеть в столбце, на котором он показывает MM, и после включения наушников он отобразит OO)

Нажмите вверх-вниз стрелки для управления звуком в наушниках. Теперь, чтобы сохранить конфигурацию, выполните следующую команду: sudo alsactl store Итак, в следующий раз, когда вы откроете свой компьютер, он загрузится с этим конфигом.

Это сработало для меня. Подумал, что было бы лучше поделиться им тщательно. В «Terminal» напишите alsamixer

В «AlsaMixer» выберите «Headphone» с помощью клавиш со стрелками в клавиатуре.

Теперь нажмите m в клавиатуре (доза мыши не работает здесь), чтобы включить наушники. (Когда наушники отключены, вы можете увидеть в столбце, на котором он показывает MM, и после включения наушников он отобразит OO) [!d4]

Нажмите вверх-вниз стрелки для управления звуком в наушниках. Теперь, чтобы сохранить конфигурацию, выполните следующую команду: sudo alsactl store Итак, в следующий раз, когда вы откроете свой компьютер, он загрузится с этим конфигом.

Это сработало для меня. Подумал, что было бы лучше поделиться им тщательно. В «Terminal» напишите alsamixer

В «AlsaMixer» выберите «Headphone» с помощью клавиш со стрелками в клавиатуре.

Теперь нажмите m в клавиатуре (доза мыши не работает здесь), чтобы включить наушники. (Когда наушники отключены, вы можете увидеть в столбце, на котором он показывает MM, и после включения наушников он отобразит OO) [!d4]

Нажмите вверх-вниз стрелки для управления звуком в наушниках. Теперь, чтобы сохранить конфигурацию, выполните следующую команду: sudo alsactl store Итак, в следующий раз, когда вы откроете свой компьютер, он загрузится с этим конфигом.

Источник

Нет звука на передней панели. Debian

Здравствуйте. У меня нет звука на передней панели. У меня слабый английский, я попробовал сам поискать решения на англоязычных форумах. Вот что получилось узнать и попробовать сделать:

В alsamixer звук на передней панели стоит — mute. Я клавишей M убираю mute, стрелками поднимаю громкость и все работает. Делаю «alsactl store» или «alsactl store 0». Перезагружаюсь — звука нет опять. Приходится опять лезть в alsamixer и повторять процедуру, либо помогает «alsactl restore».

Рекомендуем:  Как отремонтировать советские колонки

Дальше непонятно как выкручиваться, еще поиск усугубляется тем, что постоянно предлагают что-то дописать в тех файлах, которых у меня даже нет. Помогите пожалуйста с этой проблемой.

Тебе бы написать, что за звуковая и как подключено к передней панели. Есть ли pulseaudio.

Подозревают что у тебя старый корпус и hda-audio подключено к ac97-передней планке и т.к. нет сигнала о подключении штекера, звук не включается. При подключении впереди, задний звук выключается?

Звуковая карта встроенная в материнку, материнка «asus p8 z77v lx». Да, действительно, передняя панель ac97. При работе звука на передней панели в наушниках, сзади звук тоже работает.

Pulse audio вроде установлен.

pulseaudio E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: Произошла ошибка при выполнении pa_pid_file_create().

значит все работает как надо. подключи к 7-у и 10-у контактам разъема на плате выносной переключатель. замкнешь — звук пойдёт на переднюю панель, разомкнешь — на заднюю.

Источник

Нет звука на передней панели на наушниках

Стоит opensuse 11.2. Встроенная звуковуха:

Уверен, что это не чисто аппаратная проблема?

Не уверен, но надо проверить все и софт и железо

Ну так начни с железа. Проверь правильно ли подключены передние разъемы, не отходит ли где чего, есть ли звук в других дистрибутивах.

С подключением вроде все Ок, системник целиком покупался.

Не знаю, тот случай, или нет, но у меня было похоже. Передний выход так же не работал, пока в BIOS не переключил его в режим AC97, вместо HD Audio.

>С подключением вроде все Ок, системник целиком покупался.
То что он покупался целиком еще ни о чем не говорит.

Я что-то в БИОСЕ ничего подобного не нашел, там только enable/disable audio

Только что загрузил Live Ubuntu — та-жу песьня, проблема очевидно hardware, кстати: как в линуксе посмотреть модель материнки?

Походу нашел обсуждение — http://www.tomshardware.co.uk/forum/256213-12-intel-dp45sg-motherboard-sound-. , но решение пока так и не понял, вроде как советуют Windows 7 ставить:), смешно

последнее ядро поставь. у меня то же самое.

И что, последнее ядро лечит проблему?

у меня вылечило.

с 2.6.33-им тоже вроде работало.

а в kmix/alsamixer не появился вывод Headphone?

Он и был раньше, ставил на полную

он случаем не на Mute?
если нет — тогда возможно железная проблема.

Не, он не mute, железная в смысле драйвера пока нет или вообще косяк в железке?

в ядре драйвер должен быть — у меня в ядре 2.6.33-ARCH аналогичная железка работает на ура.

У меня имеется один корпус с разъемами для наушников и микрофона,спереди под крышечкой.Тоже с гарнитурой ничего не работало.Стал разбираться и выяснил,что авторы корпуса намудрили пытаясь сделать разъемы универсальным для АС97 и HDA.С разъема выведены два шнурка для подключения к плате,один AC97 другой HDA.В итоге аккуратно припаял кнопочку для правильного включения этого дела.Теперь всё работает.Корпус кстати gigabyte.

>Стал разбираться и выяснил,что авторы корпуса намудрили пытаясь сделать разъемы.

+1
Была такая проблема, дело в корпусе (вернее, в разводке разъёмов).
Выход — либо забить, либо вынуть платку разъёмов из корпуса и разобраться с разводкой.

Источник

New Style Sound
Adblock
detector